Xpress Insight 5.2 Compute - On-premises
Xpress Insight Compute is the technology component that enables remote execution of Xpress Solver and Xpress Mosel. Insight Compute is built on Xpress Insight 5, which is based on an industry-standard architecture that is scalable, secure, and resilient. Enterprises and users have a wide array of choices to integrate with the Xpress Solver and Mosel for remote execution.
The Xpress Insight 5.2 Compute Interface release focuses on API standardization.
Key features of this release include API standardization:
To learn more about Xpress Insight 5 Compute Interface, see the announcement of the launch and refer to the Xpress Insight 5 Compute guide.
Xpress Insight Compute is the technology component that enables remote execution of Xpress Solver and Xpress Mosel. Insight Compute is built on Xpress Insight 5, which is based on an industry-standard architecture that is scalable, secure, and resilient. Enterprises and users have a wide array of choices to integrate with the Xpress Solver and Mosel for remote execution.
The Xpress Insight 5.2 Compute Interface release focuses on API standardization.
Key features of this release include API standardization:
- All REST endpoints have been revised to adhere as closely as possible to accepted REST/HTTP industry best practices. The Compute Interface guide has been extended to explain the basic concepts used and shows how to use the newly designed API.
- Going forward swagger UI can be used to conveniently navigate through the REST API documentation. The swagger UI can be opened in your browser <INSIGHT_URL>:swagger-ui/, e.g. localhost:8080/swagger-ui/.
- Due to renaming and restructuring, the paths have become more concise overall. The API base has moved from /insightservices to /api.
- Some endpoints for the Insight apps have been made private for XI5.2 and will become public again with the release of Insight 5 Interactive.
- All hyperlinks are now relative, URLs returned in responses by requests and URLs returned in objects in events.
- The OAS requires major revision content negotiation which means that all requests must specify an extra accept header which includes the media type. Only the major version number of the API may be used.
- The API uses standard HTTP status codes from RFC-7231 and RFC-4918 to indicate success or failure of a request.
- Timestamps are in ISO-8601 format in accordance with RFC-3339 and are in Coordinated Universal Time (UTC).
- All examples (.NET, Java, Python and Xpress Mosel) in the XI5 developer kit have been updated to reflect these changes.
To learn more about Xpress Insight 5 Compute Interface, see the announcement of the launch and refer to the Xpress Insight 5 Compute guide.
Updated 5 years ago
Version 3.0FICO
Community Manager
Joined July 21, 2025
FICO® Xpress Optimization Blog
Follow this blog board to get notified when there's new activity