AnsweredAssumed Answered

Invalid MEX-file and E-350 in Xpress Matlab-interface (Mac OS)

Question asked by bruh on Feb 27, 2018
Latest reply on Mar 5, 2018 by Livio Bertacco

I receive the following the following error when trying to check the current Mosel version:

 

>> moselexec -v

Invalid MEX-file '/xpress/matlab/moselexec.mexmaci64': dlopen(/xpress/matlab/moselexec.mexmaci64, 6):

Library not loaded: libxprs.dylib

  Referenced from: /xpress/matlab/moselexec.mexmaci64

  Reason: image not found.

 

I've currently downgraded to 2016b from 2017a to check if that solved my problem, but no luck. I've tried to change the file permissions to rwx for all of the .mexmaci64 and .m files in the /xpress/matlab/ directory. I also tried to move the missing .dylib files to the /xpress/matlab directory. This worked and was able to return the correct version of Mosel, but when I tried to run burglar.mos, I received the following error: Mosel: E-350: Module `mmxprs' not found. I restarted Matlab and now I'm back to square one with the Invalid MEX-file error..

 

This is very frustrating and I can't find a specific installation guide or help for Mac OS.

Outcomes