ss r

BA 655 .NET Custom database Provider - Issues in RMA

Discussion created by ss r on Sep 23, 2009
Latest reply on Oct 15, 2009 by PhaniCharan Paladugu

Hi,

 

I am using a Custom database provider in BA 655 NET. I have couple of providers in my dll with one being a DB provider.

 

The DB provider works fine in the IDE. the Desc is shown in the instance drop down while the code is put into the SRL. The values change properly also.

 

The issue is when I generate the RMA and open the instance file up.

 

---------------------------
Message from webpage
---------------------------
com.blazesoft.rma.NdRMAException: Error at node 'vhPRuleset.vhPRules[0].vhTest': Object reference not set to an instance of an object.
java.lang.NullPointerException: Object reference not set to an instance of an object.
   at com.blazesoft.template.engine.NdInstanceFailedValidationException.<init>(NdValuedInstance instance, String value, String[] allowedValues)
   at com.blazesoft.template.engine.NdValuedTemplate.validateInstantiationValue(NdTemplateParameter param, NdValuedInstance inst, String value, Boolean errorIfInvalid)
   at com.blazesoft.template.engine.NdValuedTemplate.validateInstantiationValue(NdTemplateParameter param, NdValuedInstance inst, Boolean errorIfInvalid)
   at com.blazesoft.template.engine.NdValuedInstance.validateValue(Boolean errorIfInvalid)
   at com.blazesoft.template.engine._NdBH.A(NdValuedInstance A_0)

 

It is picking up the dll file for sure because the other custom provider is working fine.

 

The dropdown appears on the screen but it has no values in it.

 

It looks like it is not able to connect to the DB.

 

I am using OLEDB Connection to connect to the DB and retrieve the values into a Dictionary.

 

Any help will be useful.

 

Thanks

Outcomes