AnsweredAssumed Answered

Loading a precompiled repository results in a exception

Question asked by bernie on Apr 7, 2016
Latest reply on Apr 20, 2016 by bernie

Hello community,

 

I have the following problem:
We use Blaze 7.3.7 and a very large repository. If we start our Webspehere server, Blaze compiled approximate 1.5h the file-based repository.
During this time, can no accesses are made to the Ruleengine and other application server break down and have to be restarted.
That is no longer acceptable to us and we have to find another solution.

 

A try for a solution is to loading a procompiled repository to eliminate the timeouts, breakdowns, etc...

Now, whatever we do (severeal repositorys, servers, operating systems, configurations,...), we always get the same error of the Blaze server:

 

com.blazesoft.server.base.NdServiceException: Service 'RegelnLeistung'. Server 'ruleserver' auf Host 'PCS*****'.
Laden des Projekts C:/test/ruleserver_service_0.adb ist fehlgeschlagen.
java.lang.IllegalStateException: unread block data
at java.io.ObjectInputStream$BlockDataInputStream.setBlockDataMode(ObjectInputStream.java:2418)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1379)
at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1988)
at java.io.ObjectInputStream.defaultReadObject(ObjectInputStream.java:494)
at com.blazesoft.objects.dotnet.NdDotNETLib.defaultReadObjectHelper(:1122)
at com.blazesoft.engines.rules.NdRuleAgent.readObject(:1347)

Once the deployment manager transfers the *.adb file as a stream the ruleengine server, it comes to the error ...

The precompilation, the deployment manager and the ruleengine server run with:(java.version): 1.6.0; (Java.vendor): IBM Corporation; (Java.vm.name): IBM J9 VM
We use the IBM WebSphere Platform 8.0.0.10 [BASE 8.0.0.10 cf101502.03] server and the Host Operating System is Windows 7, version 6.1
Of course we tried encapsulated on a development environment under Linux.

All try running with a small test repository, and not with the big productive repository.

 

Has anyone a tip or help for this problem?

 

Regards

 

Bernhard

Outcomes